FR EN ES PT
Naviguer dans les forums 
Trackers Ankama

Problème avec la barre d'action sur Linux

Par Batfu 03 Août 2014 - 19:56:47
AnkaTracker

Bonjour,

Je viens reporter un problème concernant l'interface des touches. Sur Windows les touches de raccourci par défauts pour la barre d'action sont : 1,2,3,4,5,6,7,8,9,0 et il marche parfaitement sur mon ordinateur. Or sur Linux (Ubuntu 14.04), lors de l'appui de ces même touches (se situant en haut des touches alphabétiques), rien ne se passe. Je vais donc voir dans l'option commande pour changer les touches... Certaine touche ne sont pas reconnu tels que le 2 le 7, le 9 et le 0.

Je vous laisse voir ce que cela donne via ces liens:

    [*]Cliquez ici (inconnu keycode 0x0 est valable pour les touches
    2,7,9 et 0)
  1. Cliquez ici

La solution est donc de:
  1. faire comprendre au jeux que les touches 2,7,9 et 0 existe => lien 1 (pas les touches du pavé numérique mais celle se situant en haut des touches alphabétiques)
  2. Avoir la possibilité de masqué le texte correspondant à la touche nécessaire à actionner pour l'action => lien 2

De plus, je n'ai pas si c'est moi, mais les touches modifiés ne se garde pas en mémoire lors du redémarrage du jeux (elles sont remises par défaut).

J'espère avoir été clair et espère une réponse de votre part ou d'une autre personne pouvant m'aider.
0 0
Première intervention Ankama
Score : 30032
Batfu|2014-08-04 20:28:23
Le jeu fourni sur le site est le bon, fluidité impressionnante (comparé à Windows et la logithèque), je peux personnaliser mes touches!! car il garde en mémoire même après un restart du jeu. malgré tout impossible de joué avec les touches au dessus du azerty.

Par défaut, Linux définit une "détection" des touches de ton clavier.

En toute logique, tu peux y accéder depuis les paramètres système dans la catégorie "clavier".

A cet endroit, tu devrait pouvoir trouver un ou plusieurs types de clavier FR. Dans le lot, il y en aura un qui n'aura pas ces problèmes de touches mal bindées.
Voir le message dans son contexte
0 -1
Réactions 18
Score : 3006

Salut :3.

Moi du coup j'ai balancé mes raccourcis sur azertyui. J'ai fait pareil sur le mac pour pas me paumer :3. c'pas idéal, mais ce problème est remonté depuis longtemps et je crois que tout le monde s'en carre *-* (on doit être 10 à jouer depuis un linux alors bon c'est pas leur priorité ...). Je trouve ça jouable, j'espère que ça t'ira. Par contre mes raccourcis restent comme je les ai modifiés. Tu dis que les tiens se reset à chaque redémarrage ?

0 0
Score : 6902

Le reset', je pense que c'est parce que Wakfu n'a pas les droits d'écriture dans un fichier de config'. (Le dossier d'installation de Wakfu sous Windows a été déplacé de Program Files aux dossiers de l'utilisateur pour cette raison entre autres, il me semble)

Edit de confirmation : En relisant la note de màj de Pandora, on peut lire à sa fin :

Préférences utilisateur : la sauvegarde des raccourcis clavier et des préférences joueur sera bien appliquée.

Génération de rapports de bugs et de screenshots : chez certains joueurs, il était impossible de générer un rapport de bug ou de faire un screenshot à cause d'un problème lié aux droits d'écriture. WAKFU utilisera désormais un dossier dans lequel l'utilisateur à les droits d'écriture, ce qui résoudra le souci.


Ton problème doit donc sûrement venir de là.
0 0
Score : 51

Merci pour les réponses. J'ai bien évidemment penser a mettre les raccourcis sur les touches azerty mais a cause du reset je ne peux pas. Il faut donc changer les propriété des dossier c'est bien cela (je n'ai d’ailleurs pas le droit de changer les propriétés du dossier wakfu car je ne suis pas propriétaire de cet élément....) ? ou alors pas de solution pour le reset ?

Après je sais pertinemment que nous somme 10 sous Linux, mais je pense que le problème est facilement résorbable même si je ne suis pas calé en programmation.

0 0
Score : 3006

Dans quel dossier est ton dossier wakfu ? Comment as-tu installé wakfu ? Par la logithèque, ou bien avec le dossier qu'on dl sur le site ?

Pour ma part je l'ai installé avec le dossier du site (info complémentaire tout en bas linux 64). J'ai quelques autres machins qui ne s'installent pas proprement sur mon ubuntu (teamspeak par exemple), du coup dans mon dossier personnel j'ai crée un dossier applications (oui oui habitudes de macuser) et j'ai mis tout mes bazar dedans. Je suppose que c'est un dossier ou les droits sont pas très restreints. Il est où le tien ? Je sais pas si ça t'aide ._. !

Pour changer les propriétés du dossier wakfu je suppose que tu as essayé en root ? Ça marche généralement.

0 0
Score : 51

Merci de l'info j'ai installer par la logithèque... du coup je vais essayer manuellement. Après j'ai pas essayer le root (pas trop envie de m'y investir j'ai déjà testé avec mon téléphone c'est énervant!!). La logithèque ubuntu est automatique et doit avoir des protection. Le dossier se trouve dans le dossier opt/ankama/wakfu.

Je te dit sa après le download.

COOOL!!!laugh
Bon je vais essayer de résumé:
NE télécharger PAS wakfu à l'aide de la logithèque ubuntu car:

  • c'est instable (je ne l’avait pas dit mais il y a des micro coupure en jeu comparable à du lag)
  • aucune personnalisation de touche possible (car réinitialisation des touches par défaut)
  • le client n'est pas le même :blink: (lors des réglages du launcher l'interface n'est pas la même ce qui montre qui ce sont 2 launcher différent).
Le jeu fourni sur le site est le bon, fluidité impressionnante (comparé à Windows et la logithèque), je peux personnaliser mes touches!! car il garde en mémoire même après un restart du jeu. malgré tout impossible de joué avec les touches au dessus du azerty.

Quoi qu'il en soit j'espère avoir aidé quelques linuxien et linuxienne wink.

En somme il n'y a plus de problème et merci à toi Lilishooter!wub

J'ai une dernière question, comment fait tu pour lancer wakfu facilement et rapidement, car je n'ai pas de lanceur wakfu (comme sur Windows ou la logithèque) je l'execute par le terminal (devoir réécrire le programme et tout et tout c'est long...). Merci.
0 0
Score : 6902

Sous Ubuntu, tu dois avoir la possibilité de créer un lanceur via un clic droit sur le bureau. Tu rentre la commande que tu tape habituellement pour lancer le jeu, t'mets une icone sympa si t'en trouve (Cliquez ici), tu valide, et hop.

0 0
Score : 3006

Oh c'est cool que ça marche. À mon avis la version logithèque est pas très à jours, moi ça installait même pas la bonne version alors bon ... C'est pour ça que le launcher n'est pas le même à mon avis. Celui de la logithèque ça doit être le vieux.

Par contre je dois bien t'avouer que pour le lancer, à part cliquer sur le script wakfu dans le dossier où je l'ai mis (je tape rien moi par contre)... Bon après je me suis jamais sérieusement penchée sur la question, ça m'empêche pas trop de dormir :p. Clic droit sur le bureau, m'étonnerai que ça marche pour moi, je suis sous ubuntu gnome. Mais en cherchant un peu tu devrai trouver. Là ça n'est plus un soucis propre à wakfu.

Sinon, pour ce qui est de la stabilité, moi je trouve pas ça fou non plus, ça crash (bon pas deux fois par heures non plus hein, je dirai une fois par jours), le chat se bloque subitement ... Cela dit je le trouve pas plus instable que la version mac finalement. C'est pas les même crash, mais au niveau fréquence, c'est comparable.

Bon jeu à toi en tout cas biggrin. Jouer pandawa sans raccourci, ça devait être drôle haha xD !

0 0
Score : 74

Si t'as un pavé numérique tu peux le faire dessus, je trouve limite plus sympa ! smile

Par contre moi j'ai un soucis en combat, les combats bug, quand j'ai fini le tour sur mon perso, son tour descend à 0 et impossible de continuer..

J'ai du reboot sur windows en plein combat pour finir..

0 0
Score : 30032
Batfu|2014-08-04 20:28:23
Le jeu fourni sur le site est le bon, fluidité impressionnante (comparé à Windows et la logithèque), je peux personnaliser mes touches!! car il garde en mémoire même après un restart du jeu. malgré tout impossible de joué avec les touches au dessus du azerty.

Par défaut, Linux définit une "détection" des touches de ton clavier.

En toute logique, tu peux y accéder depuis les paramètres système dans la catégorie "clavier".

A cet endroit, tu devrait pouvoir trouver un ou plusieurs types de clavier FR. Dans le lot, il y en aura un qui n'aura pas ces problèmes de touches mal bindées.
0 -1
Score : 3006

Moi j'utilise un clavier mac donc à part le preset mac j'ai pas trop de choix de mappage haha :3. Celà dit, ça fait déjà deux preset claviers touchés (le mac et le azerty standard) donc y'a fort à parier que les autres soient pareils ^^. Je n'ai pas de soucis d'affiliation de ces touches sur d'autre logiciels, ça laisse penser que le soucis vient de wakfu ...

Dark je pense que ton soucis mérite un rapport de bug.

0 0
Score : 1428

Pour ma part j'ai le souci avec ces touches là sous Linux, mais c'est pas localisé sur Wakfu, j'ai exactement le même souci sur LoL (oui, en bidouillant un peu on peut lancer LoL sous Linux et ça tourne d'ailleurs très bien)...

Cela dit j'ai vu passer une réponse sur un autre sujet traitant du même souci où la personne avait justement trouvé un mappage qui bindait correctement toutes les touches, malheureusement elle n'est jamais revenue dire lequel c'était :x...

0 0
Score : 6902
LiliShooter|2014-08-05 09:41:33
Par contre je dois bien t'avouer que pour le lancer, à part cliquer sur le script wakfu dans le dossier où je l'ai mis (je tape rien moi par contre)... Bon après je me suis jamais sérieusement penchée sur la question, ça m'empêche pas trop de dormir :p. Clic droit sur le bureau, m'étonnerai que ça marche pour moi, je suis sous ubuntu gnome. Mais en cherchant un peu tu devrai trouver. Là ça n'est plus un soucis propre à wakfu.
C'est un truc de gnome, qu'on peut retrouver sous MATE entre autres. Mais Ubuntu embarque gnome de base, c'était pas vraiment inutile de préciser je pense. Ca ressemble à ça :



Pour les raccourcis sinon, sur un vieux sujet d'2012, un type avait balancé une config' d'xmodmap.
Tonkar-san|2012-03-23 19:53:14
Bon comme d'hab la priorité n'étant pas pour ceux qui utilisent linux... Là n'est pas le sujet.

Je vais vous mettre de quoi jouer avec les raccourcis !
Veuillez noter cependant qu'après la modification pour écrire les accents et autres touches affecté vous devrez faire un shift. (e.g. : Pour faire un é vous devrez faire "shift" + 2), mais les raccourcis en combat marcheront !!

Faites vous un fichier texte avec ceci que vous nommez par exemple wakfu_xmodmap :

keycode 10 = 1 ampersand NoSymbol ampersand
keycode 11 = 2 eacute 2 asciitilde oneeighth asciitilde
keycode 12 = 3 quotedbl 3 numbersign sterling numbersign
keycode 13 = 4 apostrophe 4 braceleft dollar braceleft
keycode 14 = 5 parenleft 5 bracketleft threeeighths bracketleft
keycode 15 = 6 minus 6 bar fiveeighths bar
keycode 16 = 7 egrave 7 grave seveneighths grave
keycode 17 = 8 underscore 8 backslash trademark backslash
keycode 18 = 9 ccedilla 9 asciicircum plusminus asciicircum

Faites vous un second fichier texte que vous nommerez normal_xmodmap :

keycode 10 = 1 ampersand NoSymbol ampersand
keycode 11 = 2 eacute 2 asciitilde oneeighth asciitilde
keycode 12 = 3 quotedbl 3 numbersign sterling numbersign
keycode 13 = 4 apostrophe 4 braceleft dollar braceleft
keycode 14 = 5 parenleft 5 bracketleft threeeighths bracketleft
keycode 15 = 6 minus 6 bar fiveeighths bar
keycode 16 = 7 egrave 7 grave seveneighths grave
keycode 17 = 8 underscore 8 backslash trademark backslash
keycode 18 = 9 ccedilla 9 asciicircum plusminus asciicircum

il vous suffira de faire pour jouer avec les raccourcis :
xmodmap wakfu_xmodmap
Et pour revenir à la normale :
xmodmap normal_xmodmap
En espérant que cela épargne certaines personnes et augmente votre plaisir de jeu sous linux.

J'espère néanmoins que Ankama décidra un jour de prendre ce problème à bras le corps.
En implémentant tout simplement des raccourcis de sorts éditables..
Celà nous suffirait wink

Bon écoutez... j'vais pas y passer ma soirée... il faut sauter une ligne avant chaque mot "keycode"...
Le forum fait sauter systématiquement mes sauts de lignes et j'ai reposté déjà deux fois.

Bon jeu à tous.
J'ai fait les sauts de ligne et ça a l'air de passer.
2 0
Score : 51

yep c'est bon en cherchant deux seconde<_< sur le site ubuntu j'ai trouvé comment créer un lanceur, merci chesshirea.Voila le lien: Cliquez ici
Dark boule, tu as très certainement un problème le lenteur ou de dysfonctionnement de ta connexion internet car le fait d'être à 0 sec m'arrive des fois en donjon avec des personnes ayant des problème de connexion.

Après pour le changement de clavier, je comprend ce que tu veux dire Hush mais IMPOSSIBLE.
Aucun clavier ne marche comme je veux (d'un coté je peux avoir les touches numérique mais je ne peux pas faire d'accent, de parenthèse et réciproquement). En allant sur les forum linuxien, on se rend compte qu'il y a une haine du verr maj afin d'obtenir les chiffres, ils préfère obtenir des majuscule sur les accents...(É,È,À,Ç)
Enfin bon je me contente des touches A,Z,E,R pour les sorts et puis ça roule! biggrin.

0 0
Score : 76

Mais sérieux qui joue encore à Wakfu, sous linux en 2017. Je suis sous ubuntu 16.07 et ce fameux bug est toujours là. Mais bon, on déterre un vieux sujet et on a une solution vieille de 2012 quand même. Par contre, il y a un problème avec la config normal_xmodmap, c'est la même que celle pour wakfu_xmodmap.

Le second fichier normal_xmodmap devrait plutôt contenir: (pour inverser la manip d'avant)

keycode 10 = ampersand 1 NoSymbol ampersand
keycode 11 = eacute 2 asciitilde oneeighth asciitilde
keycode 12 = quotedbl 3 numbersign sterling numbersign
keycode 13 = apostrophe 4 braceleft dollar braceleft
keycode 14 = parenleft 5 bracketleft threeeighths bracketleft
keycode 15 = minus 6 bar fiveeighths bar
keycode 16 = egrave 7 grave seveneighths grave
keycode 17 = underscore 8 backslash trademark backslash
keycode 18 = ccedilla 9 asciicircum plusminus asciicircum

 

0 0
Score : 559

 

IgnisingDhaos|29/09/2017 - 12:55:37
Mais sérieux qui joue encore à Wakfu, sous linux en 2017.


Moi :-D
Merci pour la rectification mais perso j'ai juste à utiliser la commande « setxkbmap » sans aucune option et ça annule toute modification effectuée avec xmodmap.

Et au final j'ai créé deux raccourcis clavier :
  • Ctrl+Alt+W : xmodmap Documents/wakfu_xmodmap
  • Ctrl+Alt+R : setxkbmap
0 0
Score : 2242

Bonjour!

Up, bug toujours présent (Archlinux 64bit). J'sais qu'on est des linuxéens et que par définition, on passe nos soirées à fix notre OS plus ou moins adapté aux trucs du commun des mortels, mais bon.
Pour ma part j'ai tout bindé sur le pavé numérique, étant donné qu'il sert de base pour lancer des phrases pré-enregistrées que personne ne configure. On aurait une idée d'où ça vient? Ou plutôt, du workaround qui a été mis en place sous Windows par les devs? (les keycodes é è ç à sont pas gérés par Java de base il me semble)

Merci d'avance.

0 0
Score : 17880

Pour savoir si ça vaut le coup, tes phrases pré-enregistrées ne se reset pas ?
Pas envie de perdre du temps et me rendre compte à la connexion que j'ai fais ça pour rien biggrin
 

0 0
Score : 559

C'est malheureusement un problème qui ne sera certainement jamais corrigé :-/

0 0
Réagir à ce sujet