FR EN ES PT
Naviguer dans les forums 
Trackers Ankama

Linux : l'updater re-télécharge constamment Java

Par RP-I 08 Août 2019 - 04:33:15

Bonjour,

J'utilise une version de Wakfu provenant de ce paquet : https://aur.archlinux.org/packages/wakfu-transition/ (j'ai également testé en téléchargeant directement la version depuis le site, le résultat est le même). À chaque démarrage, le launcher prend l'initiative de re-télécharger la version de Java fournie par Ankama alors que Java JDK 8 est installé sur mon système (testé avec les versions OpenJDK et celle d'Oracle) et que la case "Utiliser la version de Java fournie par Ankama" est décochée dans les options du launcher. Pire, si je règle les mises à jour sur "Me prévenir lorsque de nouvelles mises à jour sont disponibles", l'updater va me notifier qu'une nouvelle version est disponible quelques minutes après qu'il ait fini de re-télécharger Java et va, si je clique sur "Mettre à jour", re-télécharger Java et ainsi de suite.

J'ai pu isoler ces lignes des logs, qui se répètent à chaque re-vérification de la version de Java, si jamais celles-ci peuvent être utiles :

Spoiler (cliquez ici pour afficher le spoil)

[08/08 04:15:15.689]{T001}INFO    btransition/src/Transition.cpp L282 : Running check script
[08/08 04:15:15.690]{T001}SCRIPT   L0   : Running preupdate
[08/08 04:15:15.690]{T001}SCRIPT   L0   : Updater version 3.11.1 1
[08/08 04:15:15.690]{T001}SCRIPT   L0   : Forcing use of the standalone/embedded jre
[08/08 04:15:15.690]{T001}SCRIPT   L0   : Custom JRE PATH /opt/ankama/wakfu/jre/bin/java  amd64
[08/08 04:15:15.793]{T001}CONFIG  btransition/src/Transition.cpp L289 : Update triggered by check script
Le problème est plutôt contraignant vu que, si la version de Java fournie est similaire au JDK d'Oracle, ça me fait un téléchargement de ~200MB à chaque lancement de l'updater, ce qui prend un certain temps étant donné ma connexion de faible qualité.

Je reste dispo pour plus d'informations, merci d'avance pour votre aide !

EDIT : J'ai suivi la recommandation de SirJauneDeau en commentaire et ai installé le launcher Ankama (la version linux est sur AUR pour les gens sous Arch) et ça semble bien mieux marcher comme ça !
0 0
Réactions 9
Score : 17626

'lut,
tu as essayé avec le launcher d'Ankama au lieu de l'updater classic ?

Kaihe le mendiant Lan toussa toussa..

Edit: Launcher
launcher (GNU/Linux)
Hmmm, les derniers commentaires datent de 2018, l'url de git renvoie un 404...
Si tu préfères l'updater classic, dans tout les cas prends l'officiel, pas de souci sur Debian avec.

'lut,
par contre tu pourras nous dire si tu as un problème
d'affichage de caractères (dans les cinématiques ou
autre) avec le Ankama Launcher ?
Perso je réglais ça (sur l'updater classic) en cochant
utiliser la version Java d'Ankama mais je n'ai
pas trouvé ça sur le launcher.

Launcher:


Updater:


- Kaihe -
le mendiant Lan, Lan le magnifique,
le banni du temple du 36ème Tonneau
1 0
Score : 487

(Fait gaffe t'as posté le lien vers la version Windows du launcher excl)

0 0
Réagir à ce sujet