FR EN ES PT
Browse forums 
Ankama Trackers

[FIXED] Wakfu instantly closes due to apparent OpenGL Error

By OtsuFus#5262 - MEMBER - March 16, 2021, 22:03:57
EDIT: The problem was solved thanks to Intimidator
The solution will be included in the replies to this thread.


First and foremost: GETTING A NEW PC IS NOT FEASIBLE.

Per title, I have not been able to open Wakfu ever since I reinstalled Windows 10.
I have been able to successfully load the Ankama Launcher.
Several fixes identified across the Wakfu forums and workarounds have resulted in no success.

Upon closer inspection of the command prompt when directly trying to run Wakfu, several errors appeared, such as: (Ref: enclosed crash log)
  1. Initiated a temporary lockdown because of exception: Too many requests to Sentry
  2. javax.media.opengl.GLException: Profile GL_DEFAULT is not available on null
  3. javax.media.opengl.GLException: WindowsWGLDrawableFactory - Could not initialize shared resources for decon

The error 1 (and subsequently the temporary lockdown) seems to be caused by the following action:
-[AWT-EventQueue-0] (ahU:97) - Initializing GLApplication UI

The errors 2 and 3 seem to be caused by OpenGL failing to load properly.
As indicated by the following line:
-Caused by: javax.media.opengl.GLException: Unable to create temp OpenGL context for device context 0x9010910

Computer Specifications:
CPU: Intel Core i5 650 (Dual Core)
GPU (Integrated): Intel HD Graphics (Core i5)
RAM: 4GB 
Drivers have also been updated to the latest available version that was released.
2 0
Reactions 4
Score : 4009

As someone who assisted him on this, I would like to point out that we have attempted the Win81RTMLie shim fix using the particular dlls he has available, and the command readout is using a batch file created using the instructions provided in another thread by Intimidator.

I feel like given having tried every conceivable workaround we could locate, and pouring hours upon hours into this with no success, only Intimidator himself can help with this.

0 0
Score : 135

I can't comment from the main (Intimidator) acc due to some forum bug since update,
apart from that I would love to help the player to try and resolve this,
you can add me in discord (@Screen#7834) and can pick up from there.

@Damien I was not able to send you a reply to your ankabox message due to the default restrictions it has, Sorry about that. ^^

1 0
Score : 96
Huge thanks to Intimidator for solving this
the solution was (step by step):

- Check driver version, If it's lower than 15.22.58.64.2993.
- Download the Zip version of the driver.
- Extract it and try to install the drivers manually.

- If the installation fails (If often does, No need to panic, Just follow the steps below)
- Download the edited inf file and copy it into where you have extracted the driver zip file go to the "Graphics folder" and paste the inf file there (Confirm file replacement when prompted to).

- Attempt 2 at manual installation, It should proceed without issues this time.

- Try to run wakfu to see if it's working or not.
- If Wakfu is up and running, then you have successfully fixed the issue and welcome back to the game.

- If wakfu still fails to load/white screen issues, Follow this tutorial.

This will help solve the problem and you can now enjoy wakfu.
 
Again huge thanks to Intimidator for helping me get back into the game.
2 0
Score : 9751
Alas! The forum issue seems to have been resolved!

Happy to help. happy
2 0
Respond to this thread