FR EN ES PT
Browse forums 
Ankama Trackers

Game doesn't start

By RadishKnight#3690 - MEMBER - February 04, 2021, 10:17:01

The Launcher works just fine and same goes for the game at the beginning but the moment i click play to actually start it just seems to crash.

I just downloaded the game and my PC is running the latest version of Kubuntu, a version of Linux, for the record

Edit; It says the server name and then crashes, don't know if that means anything i just wanted to be more specific
 

1 0
Reactions 4
Score : 428

Hi RadishKnight,

I had a very similar issue and posted a solution in this thread:
https://www.wakfu.com/en/forum/36-technical-issues/238144-ubuntu-unable-launch-game-using-ankama-launcher-solved

Since it could be related you might have a chance by trying this:

The problem is that anakma is delivering a misconfigured launcher and a slightly misconfigured java package.

1. You need to find the file zaap-start.sh which is in the installation directory. This file has a line

java ${java_xms} ${java_xmx} ${java_options} \

this line is starting whatever java version is GLOBALLY installed on your computer. There might either be a wrong java version installed or no version at all. You have to make the line call the java version that is shipped with wakfu.

2. change that line to:

./jre/linux/x64/bin/java ${java_xms} ${java_xmx} ${java_options} \

In the very unlikely case, that you are working on a 32 bit linux machine, the path might be slightly different. The \ character indicates that the command continues on the next line so make sure that there is no blank line in beween this line and the following line. By doing that, you change the call to the binary "java" that is located in the folder jre/linux/x64/bin (relative to the current position) instead of the globally installed java binary.

3. after that you have to change from the folder where the file zaap-start.sh is, into the folder jre/linux/x64/bin

The problem here is, that anakma delivered a java package without adjusting the file permissions. The java binaries are not flagged as allowed for execution.

4. In that folder, just call the following command:

chmod u+x *

By doing so, you allow the binaries in that folder to be executed by the owner (which should be you).

I had to do this procedure on several installations and it worked all the time. Ofc you need some very basic understanding of how the linux command line interface works to be able to apply this fix. Maybe ask a friend or a family member if you feel uncomfortable working with the cli.

This issue is existing for quite a while and it would be very, very easy to fix. I don't know what's keeping the deployers from fixing it.

0 0
Score : 53

The game boots up, the issue is that once I click on my character and choose play it says "Incram" (might be wrong haven't open the game in a while) but then the game crashes.

I didn't correctly explain it in my post but if the solution is the same please say so

0 0
Score : 22

 

The game boots up, the issue is that once I click on my character and choose play it says "Incram" (might be wrong haven't open the game in a while) but then the game crashes.

I didn't correctly explain it in my post but if the solution is the same please say so
RadishKnight#3690|2021-02-20 13:38:33

I have this exactly same problem: I launch the game, select/create a character, hit play, and then the game freezes on the "Incarnam" loading screen for a few seconds and finally crashes and exit.

Character name is Mollevna.
Last play attempt was today, 2022-12-04 08:28.
I believe the map name is Incarnam, because the loading screen title.
I'm trying to play at Rubilax server.

I'm launching the game by the appimage launcher downloaded from https://download.ankama.com/launcher/full/linux/x64 .

I'm under Manjaro Linux, Kernel 5.15.78-1 x86_64.
Intel Core i7-7700HQ, 16GB RAM, Nvidia GeForce Gtx 4GB
Mesa Intel HD 630

Thank you verymuch gobberwart#2465 for trying to help, but the solution proposed didn't worked. In fact, when I was following their instructions, the java call inside the file zaap-start.sh was already calling for the bundled jre and the contents of the folder ./jre/linux/x64/bin already had execution permission. The problem lies somewhere else.

I'll provide my logs from $HOME/.config/zaap/wakfu/logs/

Wakfu logs folder, zipped

I'll also open a thread dedicated for this issue, because I thik "Game Doesn't Start" is not clear or specific enough of a title for this particular issue. After all, the game does start. The map doesn't load. There is a difference.

Thank you for any help, thou.
0 0
Score : 1

Hello, i was having the same problem as you. After several searchs, i found something that made the game work. First of all, i had to modify "zaap-start.sh"(found in ~/.config/Ankama/Wakfu/ and change the line that gobberwart#2465 gobberwart#2465 said(check his comment).

After that, i was not able to play, then i found this:

https://cst1.fr/linux/2022/02/25/Running-Wakfu-linux.html

Thats says that the problem was a "coredump", related to some native linux libraries(libraries related to VLC player), found in the Wakfu game.

Those libraries were located in
~/.config/Ankama/Wakfu/natives/vlc-linux

And had the following names:

libvlccore.so  libvlccore.so.8  libvlccore.so.8.0.0  libvlc.so  libvlc.so.5  libvlc.so.5.5.0

What i had to do to make the game work was:

Go to
/usr/lib

Copy

libvlc.so.5.6.1 (libvlc.so.5.x.x, depending of your version)

libvlccore.so.9.0.1 (libvlccore.so.9.x.x, depending of your version)

And paste them into

~/.config/Ankama/Wakfu/natives/vlc-linux

After that, i noticed that there were 6 libraries, 3 of each one( they were the same), so i tried to change its names(as the author says in the link) for the original ones, then i do this:

libvlccore.so.9.0.1  > libvlccore.so  libvlccore.so.8  libvlccore.so.8.0.0
(I deteted those libraries, and copied the libvlccore.so.9.0.1 3 times, with those names)

libvlc.so.5.6.1 > libvlc.so  libvlc.so.5  libvlc.so.5.5.0
(The same, deleted those 3 ones and copied the libvlc.so.5.6.1 and used these names).

After that, i launched the game, and IT WORKED!!!

Tested with the AppImage Launcher(download from the official Wakfu page) in Arch-Linux

Arch Linux x86_64
Kernel: 6.1.8-arch1-1

Note: I installed previously "OpenSSL-1.0", but im not sure if it has modified something.
From here(AUR): https://aur.archlinux.org/packages/openssl-1.0




 

0 0
Respond to this thread