FR EN ES PT
Browse forums 
Ankama Trackers

Cannot open Wakfu from Ankama Launcher on Mac

By ErFunka - MEMBER - October 12, 2019, 16:53:12

I keep trying to uninstall and reinstall both Wakfu/Ankama Launcher and Java but still not opening. Everytime I try it does not even open and a window pops up saying that was unexpectedly closed and if I want to reopen it. 
Of course I try reopening it but nothing....
 

Ok I have solved the problem by myself. The actual problem seems to be the fact that the current client version does not support the last version of java JDK which is the 13th. Therefore, trying to open the window from every client/launcher the game would crash. 

I have installed JDK 8 and the game is now working. 
Java JDK 8 can be downloaded directly from Oracle website, I post here the link for your ease: 

https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

being a previous version of the software it will require you to register for an Oracle account (when it asks for Company's name and Office Phone number just put random figures, it is not going to check anything)

I am playing it from the Steam launcher, haven't tried yet from the Ankama launcher but i believe i would be the same.

I hope to have helped other people with the same problem. Enjoy

0 0
Reply
Reactions 2
Score : 3226

Thanks for opening this thread.   A couple of days ago I updated to Catalina (MacOS 10.15.0) and now I am getting a blank client window when I try to open the Wakfu with the Ankama Launcher.

I did download Java 8, but not sure if the same register number as yours, I will try your link instead.
Ah, is exactly the same.  "Mac OS X x64", but you just remind me some "improvements" I did through the Java Console, although I though Wakfu was supposed to ignore those.
Let me check...

System Preferences >> Java
Hmm, did not open the Java Console this way, will try from the Terminal.
"Force Quit" window says is "unresponsive"Last login: Sun Oct 20 10:16:17 on ttys000
[email protected] ~ % java -version
java version "1.8.0_231"
Java(TM) SE Runtime Environment (build 1.8.0_231-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.231-b11, mixed mode)
[email protected] ~ % I tried to start the Java Console from here, but I was not successful.  So that is a dead end.  sad

Also,  besides the Ankama Launcher, I also tried the Wakfu Updater, but the same result; a blank Wakfu Client Window that cannot be accessed.

I ran out of ideas at this point,  I will consult it with the pillow and try another approach if one comes to mind after I wake up.  :\
 
 
UPDATE Oct-22-19:
I was able to fix it, I am sharing my solution in "general conversation" forum.
But in short, remove all possible source of Java, Wakfu (including deleting Steam!) and then download and install the Ankama Launcher and then download and install the Java 8 from Oracle. :\
 

0 0
Reply
Score : 1

the game won't be on steam starting nov 5th thou
and I'm having a problem as well...

0 0
Reply
Respond to this thread