Browse forums 
Ankama Trackers

Possible solution to get Wakfu Running on PC's with Intel integrated graphics. [White/Black Screen Fix][Win10][OpenGL]

By iNTiMiD4T0R#9728 - MEMBER - April 04, 2018, 06:04:53
The issue can be accessed here :
Update 1.59 breaks Wakfu client on PC's with Intel integrated graphics.
I had the same issue, so I went around looking for solutions to get the game running on my system.
Original post from where the solution was taken :
Some Minecraft installs not working under Windows 10

Note : This procedure is aimed at Intel i3 based machines who have a display driver version above /

| If your display driver version is below the one mentioned above, then please look up ways to upgrade your graphics drivers to the version mentioned above or higher before using the methods. Unless the drivers are above the version number mentioned, It has a very low chance of working. |
 Method After Updating the display drivers :
  1. Open CMD as Admin (Windows + X --> Command Prompt (Admin))
  2. Paste this line into the cmd and press enter.

Spoiler (click here to show spoiler)

copy C:\WINDOWS\system32\ig4icd64.dll C:\WINDOWS\SysWOW64\ig4icd64.dll
  •  Run the tool below to patch the files. (Ignore any error messages)

Required tool:

Alternate Link here :
  • Paste this line after patching is done into cmd.

Spoiler (click here to show spoiler)

copy C:\WINDOWS\SysWOW64\ig4icd64.dll C:\WINDOWS\system32\ig4icd64.dll
 Not recommendedGeneric file replacement method :
 1. Download the zip or RAR file : Fixed Intel driver files
2. Extract it.
3. Copy the extracted files and paste into  C:\WINDOWS\system32\

Video for windows defender users :

Launch the game from the client and it should be running fine. 

Procedure for i3,i5 - Driver Version check / Manual installation

1. Check graphics driver version, : How to check version

Check whether if it is lower than /
Proceed to the next steps if the version is lower |

(If it is higher; Then follow the patching guide above)
2.  Download the driver in zip format from Intel : Here
Or use the modified driver, which can skip steps 4 & 5
Modified driver download : Drivers - Google Drive

3.  Extract it to somewhere and try and check if you can install it manually : Guide here about manual driver installation

4. If the installation fails (If often does, No need to panic, Just follow the steps below) Download the edited inf file  (Thanks Otsufus)

Copy it into where you have extracted the driver zip file. 

Paste the file inside the Graphics folder and confirm replace when prompted.

5. Attempt manual installation of the drives again, following the same guide above. It should get installed.

Manual [Pre Patched] - Only for driver version /

1. Follow the driver update procedure mentioned above if your driver version is not the one listed above.
2. Download the file : ig4icd64 - Patched []
3. Extract and paste it inside C:\Windows\System32
4. Replace file if prompted.
5. Done.

macOS :
  • Fixing black screens on Mac devices can now be done via the Ankama Launcher. Users who experience the issue will be able to solve it via the "Repair" feature.

Welcome back to Wakfu.

P.S. This is a harmless procedure to your system. But be cautious just in case, not to cause any other issues by tweaking the commands. Follow the procedure.
The tool []
might trigger some alarms in some av's. You will have to disable your antivirus and use another browser than chrome to download the file. It is a nuisance but, This is the way. 

Proper Formatting : Google Docs Version

Updated : 26/12/2022
  •  Version removed from title.
  • Manual file replacement method added for only driver version 2993. (15/07)
  • macOS Big Sur issue resolution added. (22/09)
  • macOS's solution removed and replaced with official method from update 1.73.1 (30/09)
  • Additional things you can try regarding driver installation and procedure
  • Modified driver links updated to direct Google Drive link (07/06/2022)
  • [*]Published a Google Docs version of the guide. (26/12/2022)
    discord @Stotena#1945 If you need more help.
32 -2
Reactions 150
Score : 2380
btw,  Intel already stopped support for HD 2000/3000

so the only way to get it work is use this way to modify intel driver
or use older version JRE (before 8u59)
or use older intel driver
or you need to buy a new graphic card
0 -1
Score : 9917
I got it working on my laptop with Intel Pentium B960 Processor and Intel® HD Graphics Driver version ( . If that one can get wakfu running, I'm positive about it running on other devices as well. smile

Need more people to test it out.
2 -1
Score : 8
Thanks a lot for this post. At the end of the post linked, there's the method that works for my 64-bit Windows 10. 
1 -1
Score : 774
Fyi --> Attempting to download that 'required tool' file sets off McAfee's virus scanner... which claims its "dangerous"... 
1 -2
Score : 8
"PS. Fixes were done using 'diablo2oo2's Universal Patcher 2.26.1'. I know that some AV may treat it as some kind of malicious software, but it is false-positive. If you don't believe me, just don't use it. I won't distribute prepatched dll files as long my fixes are generic.

... Universal Patcher itself is often detected as malicious software, becouse it is usually used to produce cracks. Also it's patches/loaders are usually recognized as virus, becouse of it's bad fame. That's all. If you don't believe me just run it within any sandbox, virtual OS to check what it do." - from the GitHub post.

If you're still interested, you can temporarily desactivate your antivirus.
1 -1
Score : 8
iNTiMiD4T0R|2018-04-04 10:18:28
That is why i have added the manual method for users who don't want to use the tool.
Without the trouble of using a tool packed with upx which your av screams as infected.

Yupe, you did, but for some reason manually replacing did not work for me. u.u
0 -1
Score : 9917
Well, Alternative methods. If one method fails the other prevails. Keep the game running fine mate.
Thank you for helping out other users on the tread as well.
2 -1
Score : 1
I tried to use the manual version (since the commands aren't in the post, or aren't showing for me at least) but I'm just getting a 'Wakfu failed to shut down properly' error now.

zaromar|2018-04-04 17:29:27
That happened to me; that's why I had to check the linked post. The solution in the last comment worked for me.


That did it. Cheers, m8!
1 -1
Score : 8
That happened to me; that's why I had to check the linked post. The solution in the last comment worked for me.

1 -1
Score : 1363
Aye I got it to work, wot?? Such sorcery!
1 -1
Score : 9917
Darkslinger|2018-04-05 16:47:50
I have a Intel HD 3000, it launch 2 error's when i send the 2 sentences.
at last Wakfu restart when i open it, but its the same, White screen :c

Its failure in copying the files, may be CMD is not running as admin.
You can also try the Alternative Method for cleaner procedure for both 32 bit and 64 bit.
Solution for 32 & 64
3 -3
Score : -10
Gracias compa me funciono! biggrin
1 -2
Score : 9917
Es bueno saber que funcionó compañero. Disfruta el juego. biggrin
2 -1
Score : 22
Tried out the alternate method and game back to normal thanks!
1 -1
Score : 9917
Welcome back to the game. smile
2 -1
Score : 1
1 -1
Score : 9917
Glad to know that mate. smile Welcome back to the game.
2 -1
Score : 257
Alternate Method :
The cleanest way to get Java x64 OpenGL programs working: just install this shim with double-click on the .cmd file after extracting the zip archive. That's all. No DLL patching needed. Admin privileges are requested at launch so no run as admin is needed.

For both 32 bit and 64 Bit : Legacy

P.S. This is a harmless procedure to your system. But be cautious just in case not to cause any other issues by tweaking the commands. Follow the procedure.
The tool might trigger some alarms in old av's. If that scares you, then just follow the manual method.  The Manual files, how ever is not generic so you have better luck with the patch any way. The alrernate method is not tested on my device so it depends on you. That is a totally no patch solution and i hope that would work out fine if you are facing other issues.

This worked perfectly and in such a simple way. Thanks man, you are a life saver.
1 -1
Score : 1
Hello, I have windows  32-bit, so I don't have the  SysWOW64 folder sad Any solution for a 32-bit system?
1 -1
Score : 9917
The Legacy method in Alternative Methods have solution for 32 bit as well. smile Hope that will fix the issue for you. 32 & 64
2 -1
Score : -46
It doesn't work its keep saying error
1 0
Score : 9917
Try  this solution : 32 & 64
3 -1
Score : 81
I have tried all the methods but i still have the white screen.At the alternate method after the install the console gives me an error saying that "couldn't find the file ..\temp\Rar$DIa0.299\legacy-igpu-64x.sdb".Any help,please ?

iNTiMiD4T0R|2018-05-04 11:21:22
You have to extract the files some where and then run the bat file to get it installed. The error is possibly due to trying to double click and run the bat file from the zip file. Extract it and try running.

I did extract it and it works now,it says that it installed the legacy igcpu files but i still have the white screen ...

i have a radeon x1300/x1550 series and i have tried all the methods but the screen is still white.Any solution ?
1 0
Score : 9917
You have to extract the files some where and then run the bat file to get it installed. The error is possibly due to trying to double click and run the bat file from the zip file. Extract it and try running.
2 -1
Score : 13
The easy fix using the .cmd file worked for me just today!
2 -1
Score : 9917
Always happy to hear that it helped some one play the game without trouble. smile
2 -1
Score : 16
1 0
Score : 5
Im runing  windows 10 on an old I7 920 chip wich has no windows 10 patch and i have recent in game UI resolutions displayed to big for my 4k monitor ,i wonder if this fix could help me but im not very tech at this and so many opinions make me confused,would it be to much to ask if someone could put a small video on the step by step process so u can try this fix? And thanks in advance.
1 0
Score : 9917
Sorry about the delay in answering this mate, The resolution issue is not a system problem, It's the game scaling issue, It will be solved within a few more major game updates. smile
2 -1
Score : -11
I would like to try the recommended method but the .exe in the zip file either doesn't extract or refuses to work entirely (Something about insufficient system resources - and then it deletes itself). I've tried all the other methods but to no avail. Please Help!
This game is like the perfect kind of RTS that I look for and I just love it.
1 -1
Score : 9917
I think that would require you to disable the security software you have, Else the 32 bit and 64 Bit : Legacy  <-- This is the simplest way to get the issue fixed up without any trouble.
2 -1
Score : 2493
An alternative to patching Intel drivers:

Since Intel officially declared the Sandy-bridge processor family as "discontinued" in June 2016, ... and Microsoft's recent Windows-10 "feature updates" (1803 in particular) have proven problematic at best on that hardware,  it seemed time to put the old Sandy-bridge box out to greener pastures.    sad

But not junked mind you... just reborn to a new life as a Linux box running Fedora Workstation version 28... which by the way, runs the latest Wakfu update perfectly.     laugh

Currently using this Linux system as an "HTPC" connected via HDMI port to a 40-inch Samsung television at 1920x1080 resolution.    A screen that large makes Wakfu quite impressive.   biggrin
0 -1
Respond to this thread