By continuing to browse this website or by clicking on the X, you consent to the use of cookies that enable us to collect site-visit statistics and offer you videos, share buttons, personalized ads, and a chat feature. Learn more and set cookie preferences X

FR EN ES PT
Browse forums 
Score : 766

Update 1.59 may lock Intel processor integrated graphics users out - TEST THE BETA NOW and report any failures!

By Lathlaeril - MEMBER - March 03, 2018, 02:27:24
AnkaTracker

Ankama's beta server updates since February 16th have a "gotcha":... It won't run on some Windows-10 systems which use Intel processor integrated graphics!   

So far, Ankama hasn't acknowledged the reports of this issue, and may just roll update 1.59 out to the regular servers anyway... so if you don't want to see the screeen-shot below on your system as your last view of Wakfu, I strongly encourage anyone with a system running Windows-10 on hardware using Intel processor integrated graphics (no dedicated graphics card) to install and test the Beta client before time runs out!    If enough people scream bloody murder at Ankama - maybe they will decide to FIX this one before rolling 1.59 out to the world.

(The failure occurs BEFORE the username / password login screen, so even users without booster packs can do this test to see if they will be locked out when update 1.59 gets rolled out to the regular servers)

DON'T SIT IDLY BY AND LET THIS BE YOUR LAST VIEW OF WAKFU:


This failure occurs because the new Beta client includes a new JRE (Java runtime) version 8 update 162 which under Windows-10 makes use of a Microsoft-provided "generic" graphics driver instead of the Intel-provided Intel processor integrated graphics driver.   

The Microsoft driver reports OpenGL version 1.1.0, while the Intel drivers report a much newer OpenGL version.   Wakfu needs at least OpenGL version 1.3.0 to run and rejects the Microsoft "generic" driver.     

Older JRE versions used the Intel provided drivers and let Wakfu run successfully - for example: the current regular Wakfu client (update 1.58) includes JRE version 8 update 45 which still uses the Intel drivers.

** Note: Changing the checkbox in the Wakfu launcher will not help --> the beta client forces use of the Ankama-provided JRE regardless of the checkbox setting.   

Also, under Ankama's terms of service section 5.2.2, users are not allowed to change any of the Ankama-provided files, (which would include the JRE files), so only Ankama can legally correct this issue.
 
7
First Ankama intervention

Hello Lathlaeril,

Thanks for the feedback, we'll share it with the team for checking.

See message in context
Reactions 6
Score : 100

wakfu is never good with intel graphic card

0
Score : 200

I am having a similar issue to this. I made a thread about it here: [1.59 BETA] WILL NOT LAUNCH ON MY MAC. I hope something can be done about it soon.

1

Hello Lathlaeril,

Thanks for the feedback, we'll share it with the team for checking.

Score : 766

The latest Wakfu-Beta client as of March 9th, still attempts to use the wrong graphics driver, no longer aborts but still fails to work  -- >  the client attempts to use the Microsoft-provided generic driver with old OpenGL support:

 INFO 03:44:23,726 [AWT-EventQueue-0] (asR:60) - ------- GL dump ---------
 INFO 03:44:23,726 [AWT-EventQueue-0] (asR:71) - GL_RENDERER : GDI Generic
 INFO 03:44:23,726 [AWT-EventQueue-0] (asR:72) - GL_VENDOR : Microsoft Corporation
 INFO 03:44:23,726 [AWT-EventQueue-0] (asR:73) - GL_VERSION : 1.1.0

While the regular Wakfu client runs successfully because it uses the Intel-provided drivers which support a newer OpenGL:

 INFO 16:49:33,251 [AWT-EventQueue-0] (ast:158) - ------- GL dump ---------
 INFO 16:49:33,251 [AWT-EventQueue-0] (ast:169) - GL_RENDERER : Intel(R) HD Graphics 3000
 INFO 16:49:33,251 [AWT-EventQueue-0] (ast:170) - GL_VENDOR : Intel
 INFO 16:49:33,251 [AWT-EventQueue-0] (ast:171) - GL_VERSION : 3.1.0 - Build 9.17.10.4459

This latest update of the Wakfu-Beta client apparently ignores the old OpenGL version the Microsoft-provided generic driver has, and attempts to start anyway, but fails due to lack of proper OpenGL support and yields this screen (with music playing in the background):


Using the Ankama-provided JRE is not an "option" with the Wakfu-Beta client, because the beta client ignores the launcher option checkbox and always forces use of the Ankama-provided JRE.   The version of JRE installed on your Windows system doesn't matter - the beta client never uses it.

 INFO 04:34:34,613 [main] (com.ankamagames.wakfu.client.WakfuClient:226) - Configuration loaded for region WESTERN (by country detection for US): config.properties
[12/03 04:34:34.738]{T000}TRA                  GAME INSTANCE L0   : INFO 04:34:34,691 [main] (dJW:107) - 1.59 (build -1 [2018-03-12 @ 04H34min34])
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:154) - java.vm.vendor = Oracle Corporation
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:155) - java.runtime.name = Java(TM) SE Runtime Environment
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:156) - java.vm.name = Java HotSpot(TM) 64-Bit Server VM
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:157) - java.vm.version = 25.162-b12
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:158) - java.runtime.version = 1.8.0_162-b12
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:159) - os.name = Windows 10
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:160) - os.arch = amd64
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:161) - os.version = 10.0
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:162) - sun.os.patch.level =
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:163) - user.language = en
 INFO 04:34:34,691 [main] (com.ankamagames.wakfu.client.WakfuClient:164) - user.country = US


Please Note: The REGULAR Wakfu client does obey the launcher checkbox, works successfully with the Ankama provided JRE (which is 1.8.0 update 45 with the 1.58 regular client. 

If I install any Oracle version of the JRE newer than 1.8.0 update 51 on the windows system and clear the regular client's launcher checkbox to make it use the system JRE, it will abort just like the beta client was, complaining of the old OpenGL version.
 
Somewhere in between Java 1.8.0 update 51 and the newer Java updates, something was changed which causes the Java runtime to only "see" that Microsoft-provided "generic" graphics driver instead of the Intel-provided ones.
 
I would have tried the beta client with the 1.8.0 update 51 JRE installed on the system, but since the beta client ignores the launcher option checkbox and forces use of the Ankama-provided JRE, that wasn't possible.
0
Score : 100

Having the exact same problem. Progress but still not enough ( . _ .)

0
Score : 73

I  have the same issue now. Sucks because I just Re-subbed yesterday...

0
Respond to this thread