By continuing to browse this website or by clicking on the X, you consent to the use of cookies that enable us to collect site-visit statistics and offer you videos, share buttons, personalized ads, and a chat feature. Learn more and set cookie preferences X

FR EN ES PT
Browse forums 
Ankama Trackers

Error: org.lwjgl.openal.OpenALException:Invalid Device problems

By September 23, 2014, 08:30:29

hello everyone ... when I run this game this error message
(org.lwjgl.openal.OpenALException:Invalid Device) pop up on my window and I can't play the game sad
any solving problem about this?

0 -1
First Ankama intervention

Hi guys,

While I check with the team, I have recommended to the other reports to also contact our support service in order to share your logs and helps us investigate, thank you for doing so.

See message in context
Reactions 12
Score : 42

I'm having the same problem, and I've found four threads now that reported this same error without replies or resolutions sad Please, someone tell us how to fix this?

0 0

Hi guys,

While I check with the team, I have recommended to the other reports to also contact our support service in order to share your logs and helps us investigate, thank you for doing so.

Score : 3

org.lwjgl.openal.OpenALException:Invalid Device

This is related to your sound card. What it is saying is that your sound card doesn't support OpenAl.

Because of this your sound card in not recognized by the game. So the game closes.

There is three fixes for this

Fix one Enter into you device manager in side your control panel, and selected sound card and game devices from the menu. Than high light your sound card and disable it. You will have to play with out sound.

Fix Two Buy A Sound Blast sound card they support OpenAl and install it

Fix Three Check to see if your manufacturer has a fix or patch that allows your current sound card to support native OpenAl libraries. Some do but not all Realtek don't give support sad

So I'm playing with out sound but atleast I can play. I hope Dev plans to support sound cards that don't use OpenAl too in the future.

1 -1
Score : 629

I found a solution for it that worked for me. It WAS related to the audio device, but it had nothing to do with my device being unsupported our my drivers needing to be updated. (That wouldn't have made sense, as I was playing the game with audio just the day before.)

It's actually an issue that occurs for me pretty often in Windows 7 with various other programs. Here is the solution that worked for me. Maybe it will work for others having this problem as well:

1. Open your start menu and in the "search" box type "services". The results should include an item that is named just "services" next to an icon of a blue gear/cog. Click on that. (Alternatively, you can type "services.msc" into the "run" command.)

2. In the Services window that opens, scroll all the way down to the item that is simply named "Windows Audio" and click on it once to select it.

3. Once "Windows Audio" is selected/highlighted, you will see two options to the left: "Stop" or "Restart". Click on "Restart".

4. Wait for windows to perform the restart of the Windows Audio service (it may take 5 or 6 seconds to finish).

5. Once the restart is complete, close the "services" window and try to launch Wakfu again.

Hope this helps someone!

13 0
Score : -7

você é melhor que muitos suportes da ankama.

0 0
Score : 109
genoforprez|2014-12-18 00:35:34
I found a solution for it that worked for me. It WAS related to the audio device, but it had nothing to do with my device being unsupported our my drivers needing to be updated. (That wouldn't have made sense, as I was playing the game with audio just the day before.)

It's actually an issue that occurs for me pretty often in Windows 7 with various other programs. Here is the solution that worked for me. Maybe it will work for others having this problem as well:

1. Open your start menu and in the "search" box type "services". The results should include an item that is named just "services" next to an icon of a blue gear/cog. Click on that. (Alternatively, you can type "services.msc" into the "run" command.)

2. In the Services window that opens, scroll all the way down to the item that is simply named "Windows Audio" and click on it once to select it.

3. Once "Windows Audio" is selected/highlighted, you will see two options to the left: "Stop" or "Restart". Click on "Restart".

4. Wait for windows to perform the restart of the Windows Audio service (it may take 5 or 6 seconds to finish).

5. Once the restart is complete, close the "services" window and try to launch Wakfu again.

Hope this helps someone!

This fixed it for me. Thanks!
0 0
Score : 1

it doesn't work for me and i dont want to disable windows sound sad

0 0
Score : 1

Thanks gonoforprez it's works for me sry i dont good speak english but thx very much

0 0
Score : 1

Thanks you, it still works, even with windows 10.biggrin 

0 0
Score : 1

thanks <3 

0 0
Score : 40

It works!
I wonder what caused the problem in the first place?  I had been playing earlier the same day.

0 0
Respond to this thread