FR EN ES PT
Browse forums 
Ankama Trackers

Wakfu Client Black Screen After Launching Game mac OS

By CaffeinatedMicrobe#5183 - MEMBER - September 11, 2021, 09:15:42

I've been troubleshooting why I can't reinstall Wakfu. Normally, I would log into Steam, launch Ankama, click play and the Wakfu client would be launched and I'd enter the game. I own a mac OS (Processor: =1.5rem2.9 GHz 6-Core Intel Core i9 ; Graphics Intel UHD Graphics 630 1536 M B. 

Things that have changed since the last time I played on this computer: 

  • I have to wiped my computer clean recently and updated to Big Sur.

I reinstalled Steam, launched Ankama, and then clicked play. Instead of the Wakfu client accessing the game, I get a black screen. 

Here's what I've checked: 
  • Firewall is off
  • [*]I completely uninstalled Java (including .jdk files) which was confirmed with 
    $ java -version
    and,
    $ /usr/libexec/java_home -V
    Both of which said Java did not exist on my computer. Then I re-installed Java SE Development Kit 8u301 (https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html). No change and still have a black screen.
  • PRIOR to installing Java 8 on my computer however, I uninstalled Wakfu, reinstalled, and restarted my computer. Even though my computer had no detection of Java (again prior to me re-installing it) I clicked play on Wakfu hoping for a "no detection of java" like error. Instead the Wakfu client opened and was still black. 
    • Looking more into this it seems that there is a ./java in the Wakfu directory (that is version 8)? I am assuming I should not have to go within and manually remove certain files within the Wakfu installment. If I do need to remove files... which ones? I saw older posts mention that there is a box you can uncheck for using Ankama's java but that option does not seem to exist anymore.
  • I also checked the settings of Wakfu in Ankama - XMS: 1048, XMX: 2048, Java Options: -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -Djava.net.preferIPv4Stack=true -Dsun.awt.noerasebackground=true -Dsun.java2d.noddraw=true -Djogl.disable.openglarbcontext
  • I have tried deleting the "userPreferences.properties" within the log file as another post suggested.

So at this point I am at a loss as to why what used to work doesn't. If anyone has any advice or maybe knows of a post that I might've missed I would appreciate it! 
0 0
Reactions 1
Score : 8556

Got some tips :

For the Mac Big Sure issue,  try running this command.

sudo /Applications/Ankama/Wakfu/post_update_mac.sh

If you did the 1.73 installation successfully Otherwise, you can get this TAR https://wakfu.cdn.ankama.com/misc/Cg.tar then untar it and run the script inside.
Do let me know if this worked out for you.
0 0
Respond to this thread