FR EN ES PT
Browse forums 
Ankama Trackers
Pinned

[Guide] How to group with your Sidekick and/or Heroes

By [Flatops] - ADMINISTRATOR - September 30, 2015, 05:03:08

Hi guys,

Here is a little help on how to group with your Sidekick or/and Heroes from the recent changes to the interface:

Step 1: Go into your Heroes and Sidekick management interface (K) and into the "Group Management" tab.

This tab will show you your list of Heroes to choose from and owned Sidekicks.

Step 2: Make sure that you have set a leader for your group.

Step 3: Simply click on the Sidekick of your choice to group it or on the Hero you wish to also group.

You will notice that if the Hero is greyed out, you won’t be able to group it and a message will show when hovering your mouse on it, telling you the reason (need to be same guild, etc.).

*If your Sidekicks do not show on the "Group Management" tab go to the "Heroes and Sidekick" tab and select "owned" to have your list of available Sidekicks populate. 

Step 4: Enjoy your newly created group!

PS: Also make sure that if your character is offered a respec, to have it done before grouping as an advice.

Rules:
Characters must not be:

  • Dead.
  • Needing a restat.
  • In the restat instance.
  • In any quest instance.

Characters must be in:
  • Same guild or no guild at all
  • Same nation

Step 5: Level up your Heroes & Sidekicks to get heroic rewards! 

If you still have this issue, try logging in with each char individually, and leave them near a phoenix.

Close your client, launch and log-in again.

Credits to
CM Sabi
Aigees 
Reply
Reactions 11
Score : 3375

Hey FT,
After testing in live server the rules for heroes system,

The second one: "Must not be needing a restat" is not working properly in some cases, since its allowing characters party inside the restat instance, or going with their heroes to it. (And this sometimes triggers more serious bugs)

Hope this can be fixed soon, or warned to other players

Also sometimes players can be stuck in server selection after a hard lag due to some of their characters not disconnecting properly, forcing a disconnection fixes the issue. (By connecting simultaneously in two clients)
 
0 0
Reply
Score : 1112

i have 2 guildless characters, both sufokian. i can't use heroes. tried following this guide. nothing.
sorry about any errors, my keyboard's broken.

EDiT: closed Wakfu all the way, restarted the game, works!

0 0
Reply
Score : 167

Any specifics on how to rank up? (how much level, exp w/e)

1 0
Reply
Score : 2774

I will say Heroes has basically ruined my game. Sidekicks are unusable, the heroes themselves are unusuable, they cannot join fights, neither can the SK's. I'm out 4k ogrines and sometimes I can't even spawn in the same dungeon as my party of guild players.

Coupled with the fact that if you interact with anything, or if your hero bugs out, you can't login unless you wait 2 hours.

You should be ashamed for releasing a service that not only has not been quality tested, but actually hinders players who have bought the service.

1 0
Reply
Score : 86

I can't even manage to do the second step.
When clicking on the icon it doesn't do anything.

1 -1
Reply
Score : 29

I am havign the exact same glitch, Not allowed to form a troupe on the remington server regardless of whatever I try, quite annoying when I paid money specifcly to use the hero system to oslo better.

0 0
Score : 2

I'm having problems as well I made a ticket and restarted everything but it's not working. The error: "You need to enable the steam overlay..." keeps popping up. I have the box checked in steam and it's not working at all. I paid for a month for the hero system. I'm really upset that I can't play what I paid for. sad

0 0
Reply
Score : 1

But i want to and why isnt free? is real money?

0 0
Reply
Score : 33

Ahhhhaa the heroes must be on the same map. My other two were at the Tut-level smile

0 0
Reply
Score : 1

Had the same problems with Sidekick and Heros, However restarting the entire game fixed everything for me.

0 0
Reply
Score : 48

I wanted to reconfirm, this happened on my Sadida today and I thought maybe I couldnt add the Companion if another character was using it, but that turned out to be untrue since they are account linked. 

I came here, then saw someone said restarting the client fixed it so I did, and Voila! I can now use my Companions. Thanks to those who contributed here smile
Turff - Sadida's Shoe on NOX (NA)
"I've turned a new leaf"

0 0
Reply
Respond to this thread