By continuing to browse this website or by clicking on the X, you consent to the use of cookies that enable us to collect site-visit statistics and offer you videos, share buttons, personalized ads, and a chat feature. Learn more and set cookie preferences X

FR EN ES PT
Browse forums 
Score : 203

[1.59 Beta] Will not launch on my Mac

By Timburland - MEMBER - March 03, 2018, 20:34:05

[EDIT 4-3-2018]
There is a solution to this problem, at least for Mac users! I found it on another forum post here: MAC OS ISSUES WITH 1.59 AND JAVA 8. I will quote Ines00's answer to this problem:

"Hi!
This morning, Owlie (Wakfu coordinator Community Manager) has written on official Discord server these words:
"Hey there! When you download Java 8 on a MAC it downloads a version for web. The required one for WAKFU is the JDK one. Download the MacOS JDK 8 here, it should work: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html "

Also, she has send this screen: "


This fixed my problem with being unable to play Wakfu 1.59 on my Mac! I hope this also helps everyone else having this problem!


[ORIGINAL POST]
This problem seems to be linked to the problem with what the Windows 10 Intel integrated graphics users are having, but since I am on a Mac, I decided to make a new thread for it to be recognized as it's own problem.

My OS: Sierra version 10.12.6
My graphics: Intel Iris 1536 MB
My Processor: Intel Core i5 2.6 GHz

When launching the Wakfu Beta version, I am greeted with this window:

And when I click the play button, I see this warning:

So it wants Java 8? Here is my current version of Java, highlighted to see it clearly:

I have version 8 update 162 installed because I read this thread: [1.59 BETA] WHEN I CLICK "PLAY" ON BETA CLIENT, IT MIS-IDENTIFIES MY GRAPHICS AND ABORTS. Wherein, someone pointed out that the beta client is using the Java 8 update 162 version and not the 161 version. So I updated to 162 because I was still unable to launch the client with version 161 (I got the same exact warnings as seen above with both versions). Well, it's still not launching.

I have yet to see an intervention by Ankama about this issue of the Beta not launching with Intel integrated graphics cards (if that's even the issue...it might be a java thing too), but I'm hoping whatever the problem is, it is addressed and soon. I am a paying subscriber to Wakfu, and I truly love this game. Please don't lock me out of it because of incompatibility issues.

I look forward to any replies. Thank you.


[EDIT] I keep editing this post to fix the broken images. Hopefully they will stay fixed this time.
2 0
Reactions 7
Score : 62

Same problem here ^

2 0
Score : 778

Not a Mac owner so don't know if the Mac client has this option, but you might want to look, (click the asterisk in the upper right corner of the launcher to bring up the options page and look for the checkbox to "Use the Java version provided by Ankama".)   

On Windows, the beta client always seems to use the Ankama-provided Java runtime regardless of the checkbox.    Doesn't help any on my Windows problem because the Ankama-provided JRE is the new one that forces use of the bad Microsoft generic graphics drivers, but who knows, your mileage may vary on Mac??    Good luck!

0 0
Score : 203

Unfortunately, no, I don't seem to have an asterisk to click on for that options window. I tried clicking on everything else though, to no avail. That little question mark does nothing, and the Wakfu W dropdown menu doesn't help either. It just takes me different pages of the website, a couple of which are 404 errors.

Thanks for the advice tho. smile

0 0
Score : 2552

I managed to access beta by deleting all my java files through sudo commands in the terminal, somehow ive manged to keep both java 6 for live server and java 8 for beta server working parallell to each other after reinstalling java 6 and 8.

I will post in a edit once ive found the correct commands for the terminal again.

Also to summarize its mostly a java problem.

0 0
Score : 1198

Come on, y'all. This needs to be fixed before the update is rolled out or you're going to lose subscribers. 

0 0
Score : 157

Someone have founded solution? sad

0 0
Score : 2552

Yes the solution is posted at the top of the post, or you can read it here: https://www.wakfu.com/en/forum/112-server-status/233894-java-8-update-small-display-issue

0 0
Respond to this thread