FR EN ES PT
Browse forums 
Ankama Trackers

Survey: Technical Improvements

By [Flatops] - ADMINISTRATOR - April 23, 2018, 14:30:00
AnkaTracker Announcements

We would like to know your technical wishlist and priorities in WAKFU! 

We have mentioned in Gamakna and in Ankama Live #1 that our team would focus on improving your gaming experience in WAKFU.   

We have identified the areas that are in need of improvement and we would like to address them in future updates, especially those regarding performance and quality of life. To help us in our endeavor, we would like for you to be involved in the process, to make sure that our priority choices are in line with yours.

We start by gathering your feedback in the comments section of this news. They will give us an idea on your preferences, and they will also help us focus on the direction we will undergo. We remind you to keep it constructive, clear, and brief as much as possible. 

With your feedback we will create a survey and share it with the whole community. The results of this survey will help us decide on what improvements to concentrate on. 

We would like to hear first your feedback on the
technical aspect of WAKFU: performance, features to refine, display, broken quests, etc.

Tell us what are the 5 (five) technical issues that you would like to be improved on? 

1. Specify the nature of the issue and in cases that it occurs
2. 
3. 
4. 
5. 



Thanks for participating!

Reply
First Ankama intervention

Hello everyone,

Just a reminder that we are currently looking for feedback about technical improvements, so this concerns matters that hamper your gameplay such as features not working properly, blocked quests, interaction with NPCs and the environment, connectivity, latency, interface, display, game crashing / freezing, installation, texture / animation loading, and the like.

We will be tackling the game's other aspects such as class balancing, new features, new content in the future. We appreciate your feedback and we're happy to hear your voice!

See message in context
Reactions 128
Score : 24

An in game reporting system for bugs & gold sellers that doesn't take you out of the game.

1 -1
Reply
Score : 2362

an actual open world mmorpg that has pvp and also has an economy that players can actually affect you know stuff you guys slowly killed the niche of the game

3 -3
Reply
Score : 9001

Purely technical, right?

Whenever you travel large distances on a mount with high speed (Gobbals, Wolfs, Dragos), the game fails to properly load stuff.
This results, in you not being able to enter your haven bag for up to a minute ("cannot enter HB during a move"-message) when you "arrive" at your destination.
You having to use teleportation points several times before they ACTUAL take effect (flashing at zaaps happen, but you still remain there).
Monster and resources only loading up bit by bit. (sucks really hard if you are searching for a race-quest-resource...).
And sometimes even "rubberbanding" back to a location several screens away from your actual(?) position (the one you currently see on your screen).

This is ANOTHER reason why the removal of most island dracoturkey spots was such a BAD idea...
You want to improve "quality of life"? Give those back for starters and don't  touch them during your Nation's revamp...

This happens REGULARY and i am pretty sure it is not an internet-speed or PC-speed related issue.
So please reply to thispost if you have experienced this issue on a similar bases.

1 -1
Reply
Score : 7078

The traveling with high-speed-mounts and it failing to load things can even get you kicked out of the game. Do that in mines, where a lot of inaccessible blocks are. They fail to load, your character is registered to be somewhere he shouldn't be, you get kicked out of the server due to "Technical issues". 
Probably a precaution to hacking the game, but it is registered falsly.

1 -1
Score : 733

Only five? There are way more issues with this game, but the five that I experience regularly every day would be:

  1. When opening map there's a good chance only the map frame will open and the map body will be transparent, so I have to reopen it. Happens either with Drago Transport or manual opening of the map.
  2. Opened inventory doesn't refresh when you change your build, so you have to reopen it.
  3. When you're sitting you can't use any item, so those are grayed out in inventory, but don't become available when you stand up until you reopen inventory.
  4. Opening inventory, nation's menu, quests menu and professions menu takes too long and each opening causes a memory leak.
  5. Wakfu uses an obsolete JAVA port of LUA which was abandoned in 2014. Why do you need LUA scripts for spell effects when those could be done in JAVA directly, and thus avoiding of having an interpreted garbage collected language inside of an interpreted garbage collected language.
6 -1
Reply
Score : 9001

Ah, yes, that map bug.... Once i tried to simply wait for it to actually load up correctly (for science).But even after 2 minutes, no change.

0 -1
Score : 4906

Big stuff
1. Perforator on rogues: It just doesn't work
2. Group finder: Hard to navigate, autoset to your level range, keeps forgetting to remove offline players, doesn't show player names, looks ugly, etc.
3. Inconsistent mechanics of armour duration and untransparent mechanics of armour piercing damage types and heal resistance generation on spells and passives
4. Timed quests not actually dissappearing if you aren't logged in, staying in your "watched quests" list and still counting the score despite not being in your quest list (q menu)
5. Almanax rewards and stasis/wakfu anvil crafts being seriously outdated
6. Xelor sinistros not inheriting stats such as willpower (as you can guess a preaty important stat for a minion that remove AP)
7. Eniripsa marks are only applied after their damage is dealt

Minor bugs, just so people don't forget
1. That dang comunity button flashing everytime i enter a nation owned territory after a login
2. Guild quest buttons not working if it resets while you are online, untill you relog
3. Not being able to do anything while under sitting emote, and not being able to perform other emotes while using a rikki emote
4. Fogger's motherfogger being called Grace in the advance post spell menu
5. The fight bubble snapping back to the current character even if you drag it by right clicking, making some starting cells inaccessible in the bigger bubbles (astrub sewers)
6. Pandawas being unable to carry certain creatures and bosses with no specific rullings explaining which ones
7. Greedy dolls attacking the user if the ultrapowerfull targets him as the target of dolls (no damage but kinda waste their turn)
8. Ouguinak Cunning fang explanation being gibberish (in truth, it makes wereouguinak steal MP instead of removing it, even though it makes it sounds like they steal hp)
9. Certain battlefield interaction menus still being untranslated from french (including BadoBiskotto)
10. Due to how movement works in chunks of movement, hunter spell from ecaflip can make you land on a space a creature will end up it's turn on, this will not interupt their movement occasionally ending them in the same cell as you with some interesting results (selfcast spells hitting the enemy), this can also happen with some teleportation spells like sand mummies in the mechamummy boss fight) while it could be an interesting mechanic on it's own, I assume it's a bug
11. Popups such as those from hovering over bubble border cells cannot be hovered over themselves, so you cannot read tooltips of the effects they will give to the target. Also they occasionally block your cursor from clicking stuff behind them. Also all black popup windows (from right clicking states in combat) cannot be hovered over themselves (cursor just turns into the "i wanna move this window" + mode), so you cannot check the AoE of their effects (for example soul harvest from spectrex the tormentor).
12.  Items not showing the stat changes if equipped, it used to work a couple years ago than was just silently removed one update
13. Osamodas unlocking the animal link and animal synergy passive way before unlocking the spell itself (about 30 levels)
14. Hot potato not being transferred if the target is struck by a weapon
15. If you classerole a target so it follows you and you walk trough a cell the target folowing you could be locked, the target will stop there, but will reappear behind you when you trigger another move. usually annoying but if you move one cell backwards, the target will walk trough you to keep up... somehow
16. Invisible costume not hiding the gear your character is wearing

2 -1
Reply
Score : 1769
INVENTORY!

Whenever you accumulate large amount of drops (low level high stasis dungeons, levelling a friend/alt) invisible items start to clatter up your inventory or the inventory "lies" about the correct position of the items.

Invis items: A slot in your inventory SEEMS to be empty but items dropped in the last fight get put on your waiting list, because your inventory does not show all items correctly.
Position: you try to order all the items you dropped and suddenly, most of them switch places or rearange themselves without you having been even NEAR the "order inventory"-button.

These issues carry over to trades as well. When the game lags just at the second you double-click an inventory item (and that happens quite often) to put it into trade window, a "double" remains in your inventory which remains until you relog or some other stuff that resets your inventory.

And of course there is my favourite: that mini lag that happens WHENEVER you try to equip/unequip  an item. This has been happening since you introduced the current "drop-down" equipment slots and TO THIS DAY, i always have a split second heart attack if it happens with an important or very rare item, like a seal of companionship and i fear for a split second that the item is gonna be lost, like with that item-disappearing-bug in late 2016 (which you people still havn't reimbursed ANYONE for, as far as i know...).
 
1 -1
Reply
Score : 1788
1. Desync and latency problem
runic recycler will fail to crush item
combo get interrupted due to game sent repeatedly input
or you suddenly cannot cast any spell in fight, you need to wait like 1~5 minutes for game to fix by itself, there will be some message about "Resynchronisation" in log

2. Text popup will block your click when in fight
if there's a glyph or anything similar on field, when your mouse hover over it, it will show a text popup say what is this (ex: border tile that shows debuff popup, or someone's body shows its KO gaudge)
here's the problem,  if you click a tile when there's a text popup under your mouse, your action will simply be cancelled, this is annoying you'll need to dodge these text popup to cast spell on a tile

3. Casting spell need to wait animation finished, or don't update in real time
some spell's casting tile will get changed after using other spell
(ex: when using elio's portal, you need wait after animation finished to cast spell through portal)
that's really annoying that you need to wait every animation complete to really cast spell
or in some case game will show a blue tile when you don't have line of sight to this tile
(ex: a tile behind a wall showing blue when you are using a spell that need LoS)
5 -1
Reply
Score : 1769

Ah YEAH, THOSE FRIGGING POP-UPS.
Happens especially often with the in-fight speed bonus selection.Hover up of one of the boni stops you from clicking theone you actually want...

0 -1
Score : 5619
01) New Player Experience
Something for the newer players mostly, but the moment I invite new players to the game, and they acquire their Astrub Knight for the first time, the Sidekick/Hero system simply does not work.

I tell them to set themselves as Leader, then quit the game entirely and relog in order for it to start working.

The same when a player becomes level 51 for the first time and unlocks their proper U.I. (With the Builder etc) - Apperently the U.I. can only be updated on a complete restart of the game, and its confusing, sloppy and unexplained.

02) Lingering/Broken mobs
Lots of lingering corpse mobs being entirely broken (Skeletons for instance).
The undead during the Boofball dungeon in Nation Quest 3 will spawn minions upon defeating the corpse. I believe the minions in the Excarnus fight have a same problem. (Excarnus might need its entire topic btw, character animations/visuals were completely broken last time I tried it)

Similarly, Cybworks remain in play when killed in upright normal stance animation. I remember them laying down before (and never understood why then either). It's like they have been broken forever.
 
03) Bwork Dungeon
Ending your turn on top of a totem in the Bwork dungeon causes characters to not be able to move or activate spells properly for a turn quite often - Sometimes you'll be able to launch a single spell or movement, but thereafter the character fully glitches.

04) Spiderweb Cocoons
The visual animation of being caught in a Spider's cocoon will often linger forever on the client side, and will also eventually cause a memory leak overtime, causing Wakfu to crash.

05) Cania Swamps
Probably the most laggy place in Wakfu - Something I think needs to be compressed graphically there, like enviromental effects or the monsters/animations.
1 -2
Reply
Score : 709

1: Group finder: Shows people that are offline, doesn't show player names. This is a big one for me. Wakfu is such a lonely game. I wish this feature would goddamn work.
2: Being unable to assign points in the Tutorial when they prompt it.
3-5: None for now.

1 -1
Reply
Score : 127

1) Broken EnvQuests in Moon island beach: when doing an EnvQuest with heroes (collecting chests, kicking crates) only the character which is visible gets XP (am i the only one?). The heroes in the background don't get XP. Have to try it out when it is about fighting monsters. Actually i only participated in collecting EnvQuests there.
2) With the Update 1.59 it got horrible to get some XP. Before the update there has been Flax/torm dungs with a nice amount of XP and (depending on the group) a quite short time to finish both dungeons. Now after the update the time to get the same amount of XP is more than 4 times as before. Technical problem: there is no real life patch for the time i can play per day, leveling got sooooooooooooooo slow that i am thinking about stopping playing wakfu.
3) After some time playing the game becomes slower and slower and then it freezes completely. Only killing this process and restart the game is possible. Maybe the developers are relying too much on the garbage collector? And having an open instance of LibreOffice slows the game down too, because it uses Java too. PC: i3-3240 CPU @ 3.4GHz, 16GB Ram (so not the slowest HW)
4) Traveling with dragoturkeys: map opens but no content visible. Reopening it is needed.
5) Using HB while grouped with heroes: if you only enter the HB on your active char, everything is fine. But when you enter the HB of one of your heroes with a different placement of gems (or objects in garden which are not there in the other Hcool there are always areas where the char cannot go onto. You can put an object on this tile and then remove it again. But when you leave the HB and reenter it, the area is blocked again.

But to be honest, the 5th point in my comment should be that you only wanna hear 5 issues. There are (sadly) much more...

0 -1
Reply
Score : 970

1. Random time outs. When I play for exteneded periods I often get logged out for inactivity when I'm in a fight or anything else. It seemingly happens at random and is alightly irritating

2. PvP wabbits. When you die in wabbits (not talking heroic) entering you cannot use any of the buffs that you had even after bisokotobaddito ends. But they still appear on your UI. You can't even fight the wabbits to reactiviate the buff so youre stuck being useless. 

3. Collecting resources I often find that I have to collect multiple times. I dont click away but if I'm coming off of my mount or moving towards the object to collect a reasource the animation starts and then stops immediatly about half the time. I can just collect it again to grab it but its just a little annoying

4. Character stats are super important in wakfu and with the new PvP system its super nice to be able to be able to see your stats accuratly. When I adjust my level down everything is fine but it's when my level comes back up to my real level is where my problems start. I see the lower level elemental mastery bonus on top of my real level and the resistances from my lower levels on top of my real level. This all corrects itself after i enter a fight but is annoying none the less.

 

0 -1
Reply
Score : 5

1 - Sometimes I plant a monster seed, it shows like it was planted, but there's no seed there.
2 - When I lost connection inside a fight with a xelor, when I rellog I cant use Timekeeper anymore, the button are available but I can't target myself with it to recover ap.
3 - Since last update the Dial hours is buggy, if you hover, it disapear while in your turn and need to hover every time you want to see them.
4 - The crushing itens system been failed is really annoying, I don't see the need of this.
5 - And there are several problems with "fludity", the game responds slowly or laggy in many ways I cant even describe every one of them here.

And good luck for ankama, love the game and the concept but it can be much better than it is. smile

1 -1
Reply
Score : 7078

1. is caused when the areas monster-population is at its upper-limit (which differs greatly from region to region). It will seed, but nothing will spawn from it.
4. The crushing not succeeding is caused when the amount of items shown in the inventory is wrong. That is tied to the invisible item-bug as well, and fixed by sorting any bag.
5. When windows are opened the game freezes until the content is loaded. Some more async would be nice.

1 -1
Score : 5

Oh and one more thing I would really love is that ankama add more max slot per account, we can't even have half of the classes available right now.
I don't find a good experience having 2 accounts, so I would like to buy more slots and have more characters.

1 -1
Reply
Score : 2611

+ i am xelor and have it bugs too
2 - When I lost connection inside a fight with a xelor, when I rellog I cant use Timekeeper anymore, the button are available but I can't target myself with it to recover ap.
3 - Since last update the Dial hours is buggy, if you hover, it disapear while in your turn and need to hover every time you want to see them.
4 - The crushing itens system been failed is really annoying, I don't see the need of this.

1 -2
Reply
Score : 147

crushing items are important for runes which give a ton of stats ohmy otherwise you'd have to constantly gather mats for handyman for dust ohmy

0 -2
Score : 466

eniripsa
changing builds down-levels all water spells by 2 levels. it's been here since the build page update. i have reported it several times, but it's still here. say i have 2 builds for my eni, in dungeon's rooms i use DD build and change it to dedicated healer build in boss room, then all the water spells become 2 level lower than the fire and air spells' levels.

foggernauts
disconnecting in fight while in motherfogger form bugs some mechanics and spells order of the fogger. this disables advance post passive which allows the fogger to move on the rail for 1mp (fogger can't move more than his mp though the railways and sides are free cells). switching to fogginator after this happens doesn't help, the spells order remains as motherfogger's spells order, makes it impossible to cast any spell, or sometimes to move.

xelor
disconnecting in fight disables the spell timekeeper. sometimes a simple relog fixes it and sometimes i have to stare to that full rollback ap without being able to use them.

feca
disconnecting in fight disables casting bubble, orb to self.

eliotrope
1. disconnecting in fight makes portals transparent to the elio, but he can still cast spells through them.
2. moving using portals (mostly for allies of the eliotrope) when the time is running out leaves the ally on the portal even though the ally ended somewhere else (not on the portal), it blocks elio's portal and it remains until the ally's turn (if they walk)
3. the map keeps going back to the center even if i drag the map to see the target that is far away from elio, makes it hard to target the enemy. this happens all the time in Steel Beak fight, elio being on the left side while Steel Beak is on the right side.

sram
animation delay on fog trap in Nyl dungeon boss room. after teleported to the target trap/cell, the sram doesn't get pushed forward right away, he gets pushed after casting another spell in that turn after teleported. sometimes the push happens on his ally turn that's next after his turn. the sram gets pushed forward after his ally casts their first spell. if the sram ended his turn facing a hole within 3 cells, then he dies falling.
 

0 -1
Reply
Score : 1341

1. If an Ecaflip stands on the cat tree and picks an AP bonus, the bonus goes to the cat tree.
2. Problems surrounding Enutrofs debt spell and casting it on Ogrest.
3. The elemental bonus mastery somtimes is not being added in stats, i also had a few fights where it was not included at all, and it took a bunch of my damage. Most of the times it does appear when one starts a fight, but sadly, not always.
4. Annoying hp bug on some characters of mine when i start the game.
5. Elios headgear is just plain ugly.

0 -1
Reply
Score : 1670

1. Auto spell deck sometimes gives an empty spell deck after you log on a character that is using auto spell on its build.
2. Cumulative lag while using heroes, needing a client restart
3. As mentioned before, team search keeps offline people on the list and has a ton of other bugs, making it impractical.
4. Huge lags on some zones, like ethernal
5. A big friend of mine cannot access the game on win 7 after last update. Even if it is a stand alone bug, its killing the game for us.

0 -1
Reply
Score : 4906

They fixed no. 5, you can now target their center cell if they are in range

1 -1
Score : 12815

1. Invisible/transparent costume turns any class gray after they use enutrof dhrellzerker/sadida tree/osamodas dragon, etc. Basically we paid for a product that doesn't work
2. sadida dolls pass their turns, specially at start of fight (this forces people to have to use the control passive so that we control them every turn).

0 -1
Reply
Score : 152

1. Allowing Osamodas to pick the summons for their adjusted level builds instead of giving them automatic ones.
2. The display of health bars is still broken, they appear in weird places.
3. As wandererAGw said, tooltips blocking the actions. Center space of Feca glyphs are a prime example.

1 -1
Reply
Respond to this thread