By continuing to browse this website or by clicking on the X, you consent to the use of cookies that enable us to collect site-visit statistics and offer you videos, share buttons, personalized ads, and a chat feature. Learn more and set cookie preferences X

FR EN ES PT
Browse forums 
Ankama Trackers
Score : 709

[Guide] Running Wakfu in GNU/Linux

By DaCrost - MEMBER - July 29, 2017, 10:50:19
                                                                      Installing Wakfu in GNU/Linux 

Looking at the forums, I haven't seen a single guide about installing Wakfu in a GNU/Linux Distribution. Maybe, that's because, GNU/Linux users have been considered as intermediate users and therefore don't need any guide, but just a bit of Google-Fu to make it work.

However, there are so many curious people who dive into this magical world, and don't even know what's a shell-script, let alone running it, and the dependencies required to make Wakfu run in linux. There are also people who although can work-around and install it with a bit of looking around, but looking at the blunder it is, skip on playing Wakfu. Well, I consider myself to be a total noob, but I think I should share this, so that everyone can very easily install Wakfu in their GNU/Linux distribution and have fun playing.

Distribution:  :Arch Linux:   

I use Arch-Linux, however, the steps are similar for other distributions too.

Procedure: 

1.) Go to the official website, and download the Wakfu Client. Make sure you choose the correct archtitecture. 

2.) The downloaded file is a tarball. Extract it, to an easily accessible location. 

3.) You need to install some dependencies. Install Java Development Kit (Set Environment Path variable too). I installed the Oracle Version from AUR. It may work with OpenJDK too. Install libpng12 from Official Repo, install OpenSSL 1.0 (Wakfu doesn't work with new version). Install openal from Official Repo for sound. 

4.) Now change directory to the Wakfu Folder. I'll put some details on it.
     
                   - Changing Directory is easy. You use `cd` (Without `  ` ofcourse)
                   - For example, I had the tarball extracted in /home/username/ directory.
                   - The archive extracted as /home/username/wakfu-amd64/Wakfu directory.
                   - So, I change directory using `cd /home/username/wakfu-amd64/Wakfu` in terminal.
                 
5.) In terminal, type: `sh Wakfu`.  
6.) The Updater will run, agree to the agreement. Enjoy your game.

Remarks:

#I haven't tried installing the Wakfu in Debian-based distributions. So, I'm not sure if the Ubuntu Software Centre's wakfu work. 

#In Arch, it's better to follow my guide, as the AUR one was not working well for me. 

#Use Open SSL 1.0 as newer versions are said to not work. 

#Don't install just libpng as it will give you error. Libpng12 and libpng are different. I've both installed, but it will work with libpng12 only, I believe. (It happens a lot in Arch. People do `aurget/yaourt -S libpng` and the libpng comes. You're supposed to install libpng12 and not the libpng.)

Thanks, for reading the guide. Hope, you have a great gaming experience.
 
                      
0
Reactions 9
Score : 40

Solved my problem, buddy! Thanks! o/

In fact there's little to no info at all for install/usage on linux. This solution will surely help other people to enjoy the game on their preferred distro. On arch-based (manjaro here) there's only one library missing (libpng12). The rest is already there out of the box biggrin
 

0
Score : 709

Good to see, that I was able to help you. The first time, I had troubles too. Apparently, Arch is too minimal, which is the reason I chose it. Had to find stuff for an hour or something before I got it working. The openssl issue was really bad. Thankfully, some good soul in Wakfu Discord told me that, I need old OpenSSL.

Anyway, have fun playing Wakfu on your favourite distro wink

0
Score : 5238
Great guide! I've been playing Wakfu on Linux for a while now and I haven't had any problem so far. In fact, I can say that Wakfu runs smoother on Linux than Windows.
(Also I'm using i3-wm, so if someone happens to have some trouble with i3-wm and Wakfu, let me know)
0
Score : 709

Cool. i3-wm was pretty cool. I used it quite a while back. But, what kinds of problem, did you get with i3-wm? I am using dwm, a more extreme case (It's suckless, lol) but even then I didn't had problem with running wakfu, and the same with i3-wm. If you don't mind, what issues did you face :O ?

0
Score : 1463

I had a bit of trouble getting Wakfu running on Debian Stretch (and I assume Linux Mint and Ubuntu distros are similarly affected.)

The hints given in the first post are quite helpful though, thought I'd elaborate for Linux Mint, Ubuntu, and Debian users.

You need libpng12.  You'll have to manually acquire it from the wheezy release, as it's not in stretch.  Same for openssl 1.0.x, which I fished up from jessie.  For 64bit machines, you need 64 bit versions.  I installed both 32 and 64 bit versions just to be sure.

Here's links I used to acquire those two mandatory things.  Lastly, using latest JRE from Oracle, 64 bit edition.

https://packages.debian.org/jessie/libssl1.0.0 <-- openssl 1.0.0
https://packages.debian.org/wheezy/libpng12-0 <- libpng12

If there were other libraries needed that aren't default installed, installing Steam covered that (it installs quite a few things.)  So I can definitely recommend installing Steam from your distro's package manager to cover any other needed libs.  Don't bother with steam_latest.deb acquired from Valve, it doesn't work, use your distro's package manager and it's copy of Steam.

0
Score : 1

I'm actually playing it on Lubuntu 18.10 without any problems. My problems with lag? None. I can even play the game alongside Discord without any problems! Like Chetar said, you'll need those packages to actually play the game. So... do some search.

Good luck!

0
Score : 709

Err... who are you talking to tongue. If that's the reader to the guide, then sorry for the misunderstanding, if me, I wrote the guide on how to get it to work tongue , and maybe you confused it for a help thread.

0
Respond to this thread